Posts Tagged ‘Blog’

Updating to WP3.0

Wednesday, June 23rd, 2010
I have tried upgrading my Wordpress to 3.0 from 2.8.4 on Monday and have got into a Big problems. I have read the requirements from WP Blog and i have checked my webhosting partner also, then i thought i can go ahead and upgrade it. Being an great intelligent :P i have taken the backup of the Code and DB by using phpMyAdmin. I didn’t bothered to check what option it’s asking for and what option i’m checking. Finally i have got my DB backup in a SQL file.Then clicked on the option inside the Dashboard for “upgrading to WP3.0″. It was successfull, amazing….Then i have launched my upgrade page, then it’s aksing for the DB Upgradation, thought I’m done with my things.I logged into the Dashboard again and was checking everything was in place. Still my blog was up and running with out any problem. I was so happy that i have done something great…..Being a monkey, i was trying to chnage the theme, omg….i was getting “500 Internal Server Error”. I have tried every option calling each page in Dashboard, didn’t work. Some error occured but i was clueless since, i need to request my hosting partner for this error. Till this time the blog was up and running.Only Dashboard had the problem, i was not even able to see a single screen after my login page.
Then i decided to roll back WP to 2.8.4, which i downloaded to local machine. I did this and then when tried accessing Dashboard, it was asking for DB Upgrade also. Till this time there was no issue. But somehow my mid was saying to roll back the DB also, since i had a back-up today morning. I launched my phpMyAdmin, then i copied all the SQL from my backup, :’(, here i have got into a deep trouble….all the tables has been successfully created and the data also has been inserted and the only table which had the problem was “posts”……it created the table using DDL and when it tried executing insert statments thrown the error. I did looooooooot of googling with that MySQL error code and did get nothing. Everything is set except all my posts :P .
I have the comments for all my posts in DB, i have the tags, categories and thier associations to the post. Luckily i had the backup of all the post made in 2010 as HTML format, Since i use “Notepad ++” or “Editplus” to compose my articles and used to save in my HDD. So all these posts has been updated without any problem. Before that i had no backup, so i tried my level best to put it back from my SQL dump. And i tried to associate the comments also.
Finally, what and where is the problem. WP 3.0 doesn’t have any problem, the theme i was using it before had some campatibilty issue with 3.0, it’ve killed all the setting in WP. The most biggest problem is my mind, i really don’t know, what made me to rollback my DB backup. Even though exporting data option in phpMyAdmin had some issues and because of that it’s not able to upload the data again. Need little more investgation here and waiting for some logs from my hosting provider. let’s see.. all together it’s big learning for me..
The final verdict here is “If a software system is running without any problem and if you are getting an new release for the same, it’s not advicable to go and install the new release, unless otherwise there is some real problem with the current version we have, if we are doing it,then we need a good plan”. :)
Digg This
Reddit This
Stumble Now!
Buzz This
Vote on DZone
Share on Facebook
Bookmark this on Delicious
Kick It on DotNetKicks.com
Shout it
Share on LinkedIn
Bookmark this on Technorati
Post on Twitter
Google Buzz (aka. Google Reader)

Will be Completely Up By Tom.

Monday, June 21st, 2010

Dear Readers,

I’m working on to upgrade my blog WP to WP 3.0 and failed :( Will bring this blog and posts up by tomorrow. Thanks for your patience…Sorry for the trouble…

Digg This
Reddit This
Stumble Now!
Buzz This
Vote on DZone
Share on Facebook
Bookmark this on Delicious
Kick It on DotNetKicks.com
Shout it
Share on LinkedIn
Bookmark this on Technorati
Post on Twitter
Google Buzz (aka. Google Reader)

One Year Mark!!!!

Monday, April 5th, 2010

Blog is one Year old now!!! The theme is Changed need to work on the Style on the new theme…let see..!!!

Digg This
Reddit This
Stumble Now!
Buzz This
Vote on DZone
Share on Facebook
Bookmark this on Delicious
Kick It on DotNetKicks.com
Shout it
Share on LinkedIn
Bookmark this on Technorati
Post on Twitter
Google Buzz (aka. Google Reader)
Get Adobe Flash player